Compatible with Vista?

  • 1
  • Question
  • Updated 3 months ago
  • Answered
hi, i have purchased Maximum Security 2017 for 6 devices. it does not seem to be able to install on my Windows Vista PC. From what i have read on your website it should still download and install on my Vista PC.
Can you please confirm it can install on Vista?
Photo of dlazet


  • 70 Points

Posted 3 months ago

  • 1
Photo of TM_JK

TM_JK, Employee

  • 2,362 Points 2k badge 2x thumb
Hi dlazet and welcome to the community,

For your concern, regarding the Trend Micro's compatibility with Vista, Microsoft has formally announced Windows XP (April 8, 2014) and Windows Vista (April 11, 2017) end of support. Because Microsoft no longer fixes issues on Windows XP and Windows Vista, it has become increasingly difficult for Trend Micro to keep users safe on these operating systems. We encourage all of our users to upgrade their PCs to a more modern operating system which will provide greater stability and security.Trend Micro continues to recommend that users upgrade to the latest supported version of an OS as soon as possible, but also understands that not everyone is able to upgrade on a regular basis, especially on older machines. In order to help our consumers safely upgrade to the latest operating system, Trend Micro Security line of products can still be installed on Windows Vista machines but with limited technical support for issues that might be encountered.

You can refer to this page for more details regarding this concern: Trend Micro's official statement for Windows Vista's Consumer End of Support (EOS)Be reminded that the latest version of Trend Micro will not be installed. You can only use lower versions of our program.

Hope this answers your concern.

Trend Micro Home Users Community