Trend Micro in Firefox still doesn't work

  • 1
  • Problem
  • Updated 7 months ago
  • In Progress
I am running windows 10 64bit, with the new Firefox 57.0.1 64bit. I am using Trend Micro Maximum Security due to expire in Nov '18, & I have firefox enabled in the TM settings yet the ticked boxes are greyed out. Everything is up to date & have followed every piece of advice in this forum. When I click the "enable in your browser" link under the greyed out ticked boxes it takes me to a TM page which is no help. I have tried searching firefox addons etc for the 3 advised TM addons & there is NOTHING from Trend Micro listed, so can't install anything. I need some advice urgently please as I have been waiting a long time for a resolution with no luck..
Photo of mdburn71

mdburn71

  • 100 Points 100 badge 2x thumb

Posted 7 months ago

  • 1
Photo of mdburn71

mdburn71

  • 100 Points 100 badge 2x thumb
Firefox isn't even listed under my social media protection, IE & Chrome both are though!!
Photo of TM_Ian

TM_Ian, Employee

  • 5,172 Points 5k badge 2x thumb
Hi @mdburn71 and welcome to the community!

We just released an update regarding the compatibility of the Trend Micro toolbar and the 64-bit version of Mozilla Firefox. You may please try to manually trigger an update of your Trend Micro program by going to the About the Software from the main console.

Once updated, enable the Trend Micro toolbar on your Firefox. You may follow the steps on this link:

Enabling the Trend Micro Toolbar on supported browsers

If the issue persists, please contact our 24/7 Premium hotline for immediate assistance. Here is the link that contains the contact information of our Premium Support:

Ways to Contact Support

We hope this helps! Thank you and have a great day! :)

Trend Micro Home Users Community
Photo of Tom Emmelot

Tom Emmelot, Champion

  • 18,972 Points 10k badge 2x thumb
Hi mdburn71

Mine advice is to uninstall Firefox and do a new install.

Kind regards,
Tom
Photo of mdburn71

mdburn71

  • 100 Points 100 badge 2x thumb
Hi  TM_Ian,

As I said, I had already tried that, I have just tried it again & just as before.. no luck, it says my updates are up to date.. but nothing enabled for Firefox.

As for the ways to contact support.. I tried that too earlier, after my original post, & the live chat function wasn't working properly!!.

Hi Tom,

My Firefox has just had a clean install so that isn't the issue.. But appreciate the suggestion.
Photo of Tom Emmelot

Tom Emmelot, Champion

  • 18,972 Points 10k badge 2x thumb
Hi mdburn71

Than my advice is to uminstall TM with the Diagnostic tool of TM and do a reg-clean with the remanent file tool and do a new TM install.
Must do the trick.
Using the Trend Micro Remnant File Remover Tool
https://esupport.trendmicro.com/en-us/home/pages/technical-support/maximum-security-2017/1104912.asp...
Reinstalling the latest version of Trend Micro Security program
https://esupport.trendmicro.com/en-us/home/pages/technical-support/1058995.aspx?_ga=1.147757687.1592...


kind regards,
Tom
Photo of TM_JK

TM_JK, Employee

  • 2,362 Points 2k badge 2x thumb
Hi mdburn71,

Thank you for the updates. We also appreciate your help here in the community Tom.


For your concern, please make sure that you have updated Mozilla Firefox and Trend Micro for you to be able to enable the Trend Micro toolbar. Please trigger manual updates to both programs.

If in case, the issue persists. You may proceed with the re-installation of the Trend Micro program. You can refer to the links Tom Emmelot or download it directly from download center and in this page.

We hope this helps! Thank you and have a great day! :)

Trend Micro Home Users Community
Photo of mdburn71

mdburn71

  • 100 Points 100 badge 2x thumb
Still no luck, done all the advise, uninstalled Twice, used the registry cleaner.. even spoke to the TM premium customer support who basically said the same as here.. After all this all I have is the TM Toolbar, but the Osprey & BEP addons are not there. Firefox is not listed under the TM social media tab of protected browsers even though it is my default, & both IE & Chrome are listed & have not used either of them, the supported browsers ticked boxes are still ticked & greyed out, & everything is up to date... so basically all I have a TM toolbar button which does nothing besides act as a shortcut to bring up the TM console, & no browsers net protection!!..
Photo of TM_Iya

TM_Iya, Employee

  • 514 Points 500 badge 2x thumb
Hi mdburn71,

Thank you for your response and updates.

We would highly appreciate if you could provide us screenshots of the issue to further check this on our end.

Please refer on the link  below for the steps to take a screen shot:

Taking a screenshot to send to Trend Micro Technical Support


Thank you and have a great day! :)

Trend Micro Home Users Community
Photo of Tom Emmelot

Tom Emmelot, Champion

  • 18,972 Points 10k badge 2x thumb
Hi mdburn71.

Osprey & Bep are not there anymore, only one Extension  "Trend Micro Toolbar should be there.
Can you put in the menu / Settings / Other Settings, the Start to "Extra Security"
And start the PC again.

Kind regards,
Tom