system crashes when full scan is ran. Always crashes when it encounters NlsLexicons0022.dll located in the WOW64 directory.

  • 2
  • Question
  • Updated 1 year ago
  • Doesn't Need an Answer
Windows 7 / Max. Security 11.0
Quick scans run without issue, but system always crashes when full scan is run and it always occurs when it encounters NlsLexicons0022.dll in the WOW64 directory. I've uninstalled the last Windows updates and re-downloaded and re-installed the Max. Security latest version. Outcome is always the same.
Photo of Vector65

Vector65

  • 120 Points 100 badge 2x thumb

Posted 1 year ago

  • 2
Photo of Tom Emmelot

Tom Emmelot, Champion

  • 16,678 Points 10k badge 2x thumb

Hi Vector65,

When you install software that uses the NlsLexicons0022.dll dependency, the software should automatically register the file for you. In some cases your DLL file may not register properly, and as a result, will provide a "NlsLexicons0022.dll not registered" error. Fortunately, you can use a built-in utility called "Microsoft Register Server" (regsvr32.exe) to re-register your NlsLexicons0022.dll file.

How to re-register NlsLexicons0022.dll from an elevated command prompt (Windows XP, Vista, 7, 8, and 10):

  1. Click the Start button.
  2. Type "command" in the search box... DO NOT hit ENTER yet!
  3. While holding CTRL-Shift on your keyboard, hit ENTER.
  4. You will be prompted with a permission dialog box.
  5. Click Yes.
  6. Type the following command: regsvr32 /u NlsLexicons0022.dll.
  7. Hit ENTER. This will UN-REGISTER your file.
  8. Type the following command: regsvr32 /i NlsLexicons0022.dll.
  9. Hit ENTER. This will RE-REGISTER your file.
  10. Close the command prompt window.
  11. Re-start the program associated with NlsLexicons0022.dll error.
Hope this will work, like to here from you.

Kind regards,
Tom
Photo of Vector65

Vector65

  • 120 Points 100 badge 2x thumb
Tom,

Thanks for taking the time and offering your assistance .  I made it to step 7 and got the following error "The module "NlSLexicons0022.dll" was loaded but the entry-point DIIUnregisterServer was not found.  Make sure "NlSLexicons0022.dll" is a valid DLL or OCX file and then try again".

I tried this command in the system32 directory, which is where the command prompt started in.  I also tried it after I changed the directory to the SysWOW64 directory where this "offending" DLL is located, but still got the same error message.  Do I need to be in a different root/sub directory?

I did on-line chat with a Trend-micro tech last night and he/she (name was Panky) had me install a hot-fix, but that didn't work.
Photo of Tom Emmelot

Tom Emmelot, Champion

  • 16,678 Points 10k badge 2x thumb
Hi Vector,

You may try to rename NlsLexicons0022.dll to NlsLexicons0022.dll.old
and see what happen.
It is no part of the OS because i got Win 10 Pro latest version an the file is not on my PC
Here from you.

Kind regards,
Tom
Photo of Tom Emmelot

Tom Emmelot, Champion

  • 16,678 Points 10k badge 2x thumb
Hi Vector,

Did you try to put the file in the Exception Lists?
https://esupport.trendmicro.com/en-us/home/pages/technical-support/1059964.aspx?_ga=1.140400243.1592768211.1480325701
Success.

Kind regards,
Tom
Photo of Vector65

Vector65

  • 120 Points 100 badge 2x thumb
Tom,

I officially raise the white flag!  I'll be asking Santa for a new computer.

I really appreciate all your help!  Have a great Holiday season!
Photo of Tom Emmelot

Tom Emmelot, Champion

  • 16,678 Points 10k badge 2x thumb
Hi Vector,

I never raise the white flag, try the SFC.exe like Linda suggest, i personal did not see that MS tool really did something ;)
Bu t like to assist you further true the whole Holiday season ;)

Kind regards,
Tom 
Photo of TM_L

TM_L, Official Rep

  • 15,740 Points 10k badge 2x thumb
Hi Tom, thank you for assisting! We really appreciated your help!

Hi @Vector65, we're sorry that our Chat Support was't able to help you.

For your issue, since NlsLexicons0022.dll located in C:\Windows\System32\ and C:\Windows\SysWOW64\ , it's a system file. Would you please refer the following Microsoft support page to run the run the System File Checker tool (SFC.exe) to check if there are any errors appearing?
Use the System File Checker tool to repair missing or corrupted system files - refer to "Run the System File Checker tool (SFC.exe)"

If possible, please let us know how it goes. If there's an error message, please provide a description or picture of the message, we'll assist you further. Thanks.

Trend Micro Home Users Community
(Edited)
Photo of Vector65

Vector65

  • 120 Points 100 badge 2x thumb
System got hung up  @ Verification 90% complete.  The following error message popped up -- "Windows Resource Protection could not perform the requested operation". 

I've tried resetting the system back to factory using the Lenovo Rescue System app, but it just reboots windows.  The system also won't let me do a restore point recovery.

I always run a quick scan on the system prior to any on-line transactions or banking and run a full scan occasionally.  I've never experienced any issues in the past when running full scans and quick scans always come back clean.
Photo of TM_L

TM_L, Official Rep

  • 15,740 Points 10k badge 2x thumb
Hi @Vector65, thanks for the reply!

We definitely want to help you to solve this issue. For your error message issue, could you please try using Safe Mode to run System File Checker. 
Here's a reference doc for the steps: 

STEP 1. Restarting Windows in Safe Mode

STEP 2. Run System File Checker to check integrity violations in the Operating System:
  1. On your keyboard, press the Windows Windows Key + R keys. The Run window should appear.
  2. On the Open field, type "cmd", then press ENTER. The Command Prompt window will open.
  3. On the Open field, type "sfc /scannow", then fix corrupted files.
After trying the steps above, if there is a different error appearing, please provide a description or picture of the message.

If you can run the System File Checker smoothly, please check if you can perform a Full Scan. If the scan issue still persists, you may log in to command prompt and check drive for errors and check if that solve your issue.

In the command prompt, type the following command and hit Enter: 
chkdsk /r

Note: If any bad sectors are found while running the check disk utility and if attempt recovery of bad sectors is checked while checking the drive for errors, the data in the bad sector may be lost while attempting to recover bad sectors.

After trying the command if the scan issue still occurs, could you please make sure your applications are all be turned off before performing the scan. And if the problem still persists, we need to specific which hardware or software on your computer is the impact factor. Please follow the instruction below to do this with The System Configuration window:
  1. On your keyboard, press the Windows Windows Key + R keys.
  2. In the Open field, type "msconfig", then press ENTER. The System Configuration window should open.
  3. Click the Services tab.
  4. First, tick "Hide all Micro soft services"
  5. Uncheck (Stopped) all items except "Trend Micro Inc.". 
  6. Click the Startup tab.
  7. Uncheck all items except "Trend Micro Inc.". 
  8. Then click Apply, then click OK.
  9. Reboot your computer.
  10. After rebooting, please performing the Full Scan.
Don't forget to return the default settings after the confirmation. If the problem is solved by above settings, we need to tick the Service items back one by one to specific which hardware or software on your computer is the impact factor.

It's quite a few steps to perform, but please do let us the result of your verification. We'll help you further when we hear back from you. Thank you very much!

Trend Micro Home Users Community
Photo of Vector65

Vector65

  • 120 Points 100 badge 2x thumb
Unfortunately the outcome is the same.

I've purchased a new computer and am ready to move on.

I appreciate everyone's tenacity and determination @ trying to find a resolution to the problem.

Everyone have a great holiday season!
Photo of TM_L

TM_L, Official Rep

  • 15,740 Points 10k badge 2x thumb
Hi @Vector65, sorry that the solution didn't work for you. 

We understand you have purchased a new computer. Please do contact us in this community if you have other questions or issues in the future. We'll be glad to help you out!

Happy Christmas! 

Trend Micro Home Users Community