spam filter does not work after update to Windows 10 Fall Creator Update

  • 1
  • Problem
  • Updated 7 months ago
  • Acknowledged
Just updated to Windows 10 Fall Creator.  When I try to enable, it disables and is not filtering spam.
Photo of kend

kend

  • 150 Points 100 badge 2x thumb

Posted 9 months ago

  • 1
Photo of TM_Isi

TM_Isi, Employee

  • 248 Points 100 badge 2x thumb
Hi kend! Welcome to the community!

Are you referring to the anti-spam toolbar on Outlook? If so, can you please check what is the version of your Trend Micro program? 

Thank you! :)

Trend Micro Home Users Community
Photo of kend

kend

  • 150 Points 100 badge 2x thumb
The anti-spam toolbar acts like it enables and then disables.  It worked before the wonderful update from Microsoft.
Photo of kend

kend

  • 150 Points 100 badge 2x thumb
I am running version 12 Trend Micro Internet Security 2018.
Photo of TM_RalphyT

TM_RalphyT, Employee

  • 562 Points 500 badge 2x thumb
Hi kend,

Thank you for the update. 

May I know if you have successfully enabled the Trend Micro Antispam Toolbar on your Microsoft Outlook? You may consider visiting the link below to guide you in doing that one:

Using the Antispam Toolbar of your Trend Micro Security

Also, may I know the Outlook version that you are using on your computer? To further guide you on that one, you may follow the steps below:
  1. Open Microsoft Outlook.
  2. On the Help menu, select About Microsoft Office Outlook.
  3. Kindly check the version information and the build number of the Outlook
We will be waiting for your reply. Thank you and have a great day! 

Trend Micro Home Users Community
(Edited)
Photo of kend

kend

  • 150 Points 100 badge 2x thumb
Version 1709 (Build 8528.2139). I enable then it disables immediately.  It has to be the Windows Creator Fall update that changed something.
Photo of TM_Victor

TM_Victor, Employee

  • 4,756 Points 4k badge 2x thumb
Hi kend,

Regarding your concern, can we still ask for the version of your Microsoft Outlook?

May we also know what came in first? Is it your Windows 10 update or the upgrade of the Trend Micro program to the 2018 version?

It is possible that there has been a possible corruption of the Trend Micro components due to the update and to fix it, it would be to clean reinstall the Trend Micro program.

You may get the Trend Micro removal tool on this link - Using the Trend Micro Remnant File Remover Tool.

After the removal, you may get the latest version of Trend Micro Internet Security 2018 and install it.

I hope this helps.

Trend Micro Home Users Community
Photo of lenvdr

lenvdr

  • 330 Points 250 badge 2x thumb
Everyone is having the same problem with the trend antispam toolbar since the Fall update, I have checked 9 machines this morning on different sites with the same result, I have made sure all have been updated the latest Trend Version available on the web, and no change, all still not working.
The Fall update also installs an update to Windows Defender / Security Essentials, that may also have something to do with the fails in Trend Spam. Another point of interest is that Trend Antispam add-in has issues with Office Outlook version 2013 and 2016, but 2010 is OK, a small drop in opening and closing performance, but in 2013 and 2016 the closing time of outlook if a spam was reported during a current session it sometime takes outlook up to 5 or more minutes to close.
So far none of these problems seem to be resolved as yet. But lets give Trend a bit of time, they are pretty good with support.
Photo of TM_Kiko

TM_Kiko, Employee

  • 10,442 Points 10k badge 2x thumb
Hello lenvdr! Thank you so much for your input on this matter. We really appreciate your feedback and the information that you have shared.

We will be investigating this issue further on our end. Please bear with us as we will need to have the issue replicated on our end.

Thank you so much.

Trend Micro Home Users Community
(Edited)
Photo of lenvdr

lenvdr

  • 330 Points 250 badge 2x thumb
Always a pleasure
Will also do more checks to try and find the reason.
I have checked many possible causes for the Spam filter slowing down closing of outlook and it seems to point to a possible file locking problem causing the slow closing, the programmers will know what I mean. Outlook seem to use file locking in places where maybe only record locking is needed.
The greyed out Spam filter has only occurred after the Fall update but again in my opinion it has something to do with the possible change the update may have done to windows defender, and defender is causing the disabling of the spam filter. 
Photo of TM_Kiko

TM_Kiko, Employee

  • 10,442 Points 10k badge 2x thumb
Hello! 

Just an update, I have consulted our specialist and this may be caused by a known issue on Outlook email application.

We can refer to this link for the Add-ins that are being disabled:

Add-ins are user re-enabled after being disabled by Office programs

We can have the Trend Micro AntiSpam Toolbar re-enabled and have it selected as Always enabled by following the same steps on the link above. There should be an option to Choose Always enable this add-in.

Hope this helps.

Trend Micro Home Users Community
(Edited)
Photo of kend

kend

  • 150 Points 100 badge 2x thumb
It still disables the AntiSpam bar immediately.  I changed to Trend Micro Internet Security Titanium when my year was up.  I uninstalled and installed the new version.  It still does the same thing as already stated.
(Edited)
Photo of TM_Jabi

TM_Jabi, Employee

  • 7,242 Points 5k badge 2x thumb
Hi kend

Thank you for your update.

Is this after following the link provided by TM_Kiko?

Trend Micro Home Users Community
Photo of lenvdr

lenvdr

  • 330 Points 250 badge 2x thumb
Yes you are correct and it is a bug in the windows update to 1709. I am currently reverting all our machines that updated to 1709 back to 1703 and believe it or not it is 24 machines in total and all have exactly the same problems, drivers messes up, Microsoft's own apps now malfunction all parts of Office so far in my tests have failed, the trend toolbar is not the only one, When in Word or Excel one can no longer send the file from within the app to email, it gives a MAPI error. Not only has Trend got problems but other AV packages are giving problems, I am now even more convinced that one of the main problems is caused by an update to Windows defender with the 1709 update. Defender is also not functioning properly anymore, on all our systems Defender was co-existing with other AV apps quite well and up to 1703 has had no problems on any of our systems whether using Trend or other AV products. I got Microsoft to log into one of our system and check it, there feedback to me was that the problem is in their automatic updates and we should revert to 1703 then download and do a manual update but I am just reverting all 24 of our machines that updated back to 1703 I have so far today done 9 machines that are working again. Trend Antispam Greyed out Spam is now also OK, but trend antispam is not fully compatible with office 2013 and causes closing down problems after reporting a spam mail, but in my opinion that is a outlook problem and still most likely a file locking problem after a spam report and the way PST files are locked, file locking instead of record locking is still most likely. Well I have a bad weekend ahead as still have to travel to sites to restore the balance of machines that updated (15 more have done 9). I will do a test on a spare machine with a manual update but am sceptical about it working so will not try on working office machines. Have also tried to block all updates for as long as possible as well as making sure that updates are all set to Current Branch for Business as that seems to be part of the problem that caused the automatic updates, it is also possible that MS will take that feature out in new versions so that they can destroy business use machines as well. I have also just been contacted by another company that has had the same problem, but are now adamant they want to go back to Windows 7.
Windows 10 is good and some features are outstanding but MS needs to make 2 versions one for Business and one for Kids and there toys where they can use the kids version for development and testing, and if the apps become useful and stable add them to the Business version.
Photo of Tom Emmelot

Tom Emmelot, Champion

  • 18,880 Points 10k badge 2x thumb
Hi lenvdr,

I got win 10 pro and i did the update yesterday while i was looking what happened with my computer and let him do al the things.
I got 200 mb internet 16 gb memory i7processor SSD drive, he was bussy 3/4 hour start the computer 2 times and the third  time i log in and also that takes a long time.
It all worked after that, but i must deal with all the things MS make the things default again and not the way i want it.
So you are right that this is not workable in a pro situation.
A other advice from me is to reinstall on all your machines TM again, I got several indications that if you go back with your system TM does not work correct anymore! Has to do with programs that got blocked in the process of reverting.

Kind regards,
Tom
Photo of lenvdr

lenvdr

  • 330 Points 250 badge 2x thumb
Hi Tom, Thanks for that info, Checked my Trend and all other apps after the revert and all seems OK. Do you use Office and if so can you send a document directly from Word or Excel without a problem? All 24 of the machines we have and they are at various sites as well as those that others have updated have reported this MAPI problem, Unfortunately it has affected the spam filter in Trend and not all of our machines use Trend, we have about 15 odd that use Trend, Others use Kaspersky but seems no problems there, but all are having problems with Defender showing "needs attention" since the 1709 update and shoes a rex cross in its Icon, on all machines with version 1703 Defender shows a Green Tick. So far of the 9 that we reverted none of them have given any problem as yet and we have checked TM and other office problems including defender and all OK. I will let you know if I pickup problems. I have not been able to get to all the other sites as yet myself but have a support person going there to stand-by during the revert to 1703. All 4 of my home machines have Top End i7 CPU's running at from 3.5Ghz to 4.2GHz, all have 256GB SSDs for System Disk, 500GB SSD for Data drive and 3TB for Main storage, 2 have 32GB Ram and 2 have 16GB, I also have a 16TB NAS for backups and as a media server for Video's etc. Wife likes her movies and I have 2 x LG 4K OLED TV's and 2 x 4K Samsung TV's.   I do a lot of Video editing as have a 4K video camera as well. That's why I need the storage and power. Looking to Upgrade my NAS by another 8TB or get a second NAS for PC Data and Cell phone backups only, as do a Bi monthly image backup of all my system disks, I don't use windows image backup as not reliable I use AOMEI Back-upper Pro. But now with Windows 10 problems I will do Monthly Image Backups. Unfortunately only have 10Mb ADSL internet but upgrading to fibre as soon as it becomes available at my location.   Kind Regards.
Photo of Tom Emmelot

Tom Emmelot, Champion

  • 18,880 Points 10k badge 2x thumb
Hi lenvdr,

Here to MAPI problems, i saw a lot of office files in the windows.old map i think there is wat going wrong with the update.
I installed office 2010 again and the problem was gone!
Hope that you get your systems all up and working again!

Good luck  and kind regards,
Tom
Photo of lenvdr

lenvdr

  • 330 Points 250 badge 2x thumb
Yes you are correct, sorry I should have got back to you sooner but have been very busy. There are several problems that was created in the update main bad ones was caused with the Office update and the Windows Defender update. to get rid of both problems you need to do a Repair on office after the update for the MAPI problem, and for the greying out of the Spam Icon you first need to fully uninstall Trend, then do all updates for the new defender, after that reinstalling Trend, all will Work There is still a small problem and that is the1709 version of defender does not properly co-exist like before with trend, but at least Trend will work fine but Defender will still complain and show a red cross in its Icon. But that does not bother me, just do not know yet what other funnies will appear later. The problem is that if defender installs after trend is installed it tries to disable trend features.
If there is a way to upload 4 small jpg clips I can show you the deference between the displays of Defender in 1703 and 1709 and the two apps co-existence. Else send me an email address and I will send it to you. It also seems that update 1709 is not ready for business use. so machines setup as Business won't get the update automatically. MS recommend you download the Update and perform it manually.
Photo of Tom Emmelot

Tom Emmelot, Champion

  • 18,880 Points 10k badge 2x thumb
Hi lenvdr,

Sorry for my late response. I still not have the Spam filter working in Outlook 2010.
Installed  2010 and later TM, i did this several times to no avail.
In between reg-clean and folders deleted, to no avail, the logo is there every-time but cant do anything with it only the info window appears if i click on info.
So hope that someone can shine a light on this matter.

Kind regards,
Tom
 
  
(Edited)
Photo of TM_Kiko

TM_Kiko, Employee

  • 10,442 Points 10k badge 2x thumb
Hello kendTom Emmelot and lenvdr,

I have reached out to our experts with regard to this matter and we will need some help from you. Will it be possible if one of our supports will be contacting you and collect logs from the affected computers with the said issue?

I just need a respondent on who would like to volunteer with this log collecting process and I will be opening a ticket based on the registered email address on this community.

Just a heads up, I will be asking for the contact information through the email that I will be sending so that our support can reach you and perform the log collecting on your most available time.

Thank you so much.

Trend Micro Home Users Community 
Photo of Tom Emmelot

Tom Emmelot, Champion

  • 18,880 Points 10k badge 2x thumb
Hi Kiko,

I am a Pugtester of TM for i think almost 20 Year and this time i did not get it running, using al the tricks that worked before! So i think it has somehow with the rights to do.
So i am your volunteer and i live in the Netherlands and think that my name and email address  is known.
Here from you, or a other TM Employee.

Kind regards,
Tom
Photo of TM_Kiko

TM_Kiko, Employee

  • 10,442 Points 10k badge 2x thumb
Hello Tom Emmelot,

We appreciate your efforts in helping us resolve this concern. I will be creating a ticket now and I will be sending the email as well.

Trend Micro Home Users Community
Photo of lenvdr

lenvdr

  • 330 Points 250 badge 2x thumb
Dear Tom, and TM. To fix the Spam-filter in trend with after update 1709 you need to do the following. Completely uninstall Trend, then do all updates on windows defender and make sure it works with no missing ticks or errors, then do a repair on office 2010 (go to uninstall and select repair) after that you then need to re-install Trend and trend spam filter with then work. You will also notice that after trend is installed it will give an red cross in its Icon and say it needs attention, do not worry about this it is just attempting to do its own checks and the Security essentials part of Defender that is installed after the 1709 update does not co-exist with Tend, but Trend will still work fine, not sure if another update of Defender will again kill trend antispam, I hope not.  The Problems are Microsoft's as they do not care about any other apps other than their own, but looking at the 1709 update it has damaged several of their own apps this time, the one was the MAPI problem, but that's far from the only one. I am sorry to say that I now only have a single machine running 1709 update so that I can keep checking when 1709 becomes stable, so fire the time being do not update to 1709 if you are in any way business critical. I have in the last few days restored over 35 machines back to 1703 as that version is reasonable up to now. As to TM-Kiko doing some tests we can arrange a time, but Trend Support have done tests and have reported the error to me a MS problem, they will be referring back to me as soon as they have an update from MS. I could not wait so resolved the problem by discovering that what was greying out Trend Antispam was actually the  Defender part of the 1709 update, but MS need to fix the problem so that defender correctly co-exists with Trend and other AV applications. It messes around with Norton as well, does not seem to disturb Kaspersky so far as I can see. will keep all updated if any other things happen. NB.  Tom if you have problems do all updates and installs as administrator (Log in as Administrator as sometimes "run as administrator" does not work for all scenarios), go to this PC-manage-local users-users and enable Admin account if it ids disabled. Kind Regards, Len
Photo of Tom Emmelot

Tom Emmelot, Champion

  • 18,880 Points 10k badge 2x thumb
Hi Len,

That last suggestion i did not tried. I shall do that, you here.

Kind regards,
Tom
Photo of Tom Emmelot

Tom Emmelot, Champion

  • 18,880 Points 10k badge 2x thumb
Hi Len,
 
I tried that install with the administrator account but to no avail.
TM has looked in to it and says that the Office 2010 has the problem and MS is not going to repair it.
It worked fine before the update. So Thanks to MS no office 2010 ad-don of  TM.
I still has the question in the MS community and hope still on a answer there.
It works with the 2013 and 2016 version.

Kind regards,
Tom
Photo of lenvdr

lenvdr

  • 330 Points 250 badge 2x thumb
Hi Tom, I have resolved 4 machines problems with the Report Spam Icon being greyed out as well as the Mapi Problem when tying to email from within a office application. All the machines fixed are using Office 2010 (the last Good version of Office). Sorry to hear it did not work for you. Is the problem you are having the outlook add-in spam filter being greyed out, and if you try to enable it again it greys out a few seconds later by itself? If this is your problem then it is defender that is doing it, so lets see what we can do to trash defender, but I myself prefer to keep defender as a backup as at least when ones AV expires defender will still work pretty well, just does not have all the features and configuration ability of Trend. Also Trend Antispam has problems with all versions of windows 10 when using Office 2013 or 2016 in that it causes outlook to take excessive time to close if at any time during using outlook you marked an Item as spam and reported it, then did a send/receive to transmit the spam-details file that trend puts into the Drafts folder. Under these conditions Outlook can take as long as 5 minutes to close. To prove this condition with 2013 or 2106 report a spam do a send receive when all has completed fully you can wait as long as you like to make sure send/receive has fully completed. Then close outlook and try to open it again, a message will say outlook is busy closing and this will persist  for some time, should you try to shut down the computer just after this you will get a message warning you that an app is still running do you wish to force a shutdown.
I am not making any drastic decisions what to do as yet. I use outlook 2013 on one of my private machines and 2013 and 2016 on some of our office machines, we no longer use office at all unless we need outlook, all other machines that do not have 2010 now use Open Office as company not prepared to use 365. we run an app for at least 6 years before an upgrade. Most of our work is Graphic so not everyone needs word or Excel that much to verify the cost of 365. one used to be able to get Outlook on its own some years ago, many are just wishing someone will bring out a standalone app that works like outlook. (contact management, appointment management/ calendar and good mail control.
If anyone wants to see the 1709 update working with the spam filter on one of my machines I could post a video or trend can contact me to check this by remote connection. Good luck to all, Len
Photo of TM_Jabi

TM_Jabi, Employee

  • 7,242 Points 5k badge 2x thumb
Hi lenvdr,

Thanks for all the inputs and ideas that you had posted. 

A video will be a great help for your fellow users as well. 

Thanks for all the help here! 

We will keep you posted about all available updates for this issue.

Trend Micro Home Users Community
Photo of lenvdr

lenvdr

  • 330 Points 250 badge 2x thumb
A video is a bit big to post on this blog but I will upload two Jpg files withg files with all the evidence of the problems and the ones I cured with added comments. I have restored all my machines back to Windows update 1703 as 1709 is a disaster at present. I do have a old backup-spare computer that we keep running in case of problems and also for testing and have kept this one updated on 1709 but have preformed all my fixes explained in my previous reply's. All apps including Trend antispam are working fine, just defender keeps showing that attention is needed, I think MS Updated features in Defender that is causing the conflict. so we have a scenario that when defender is loaded or updated after trend is installed then Trend fails with the spam problem getting disabled and when trend is installed after defender then Defender gets its AV section blocked. The last person arriving killing the currently resident person scenario. Any way hope these uploads get to you and any others having the same problem, Regards Len. Regards Len.
Photo of Tom Emmelot

Tom Emmelot, Champion

  • 18,880 Points 10k badge 2x thumb
Hi Len,

Installed office 2016, also same problem so try to follow your prescription but to no avail.
So TM must contact MS what this failure causes!
Still no resolution on MS community!

Kind regards,
Tom