Password Manager not locking automaticaly on Webpage inactivity.

  • 1
  • Problem
  • Updated 2 months ago
I have had this issue for quite a while, although I don't always notice it because I manually lock Password Manager but occasionally forget and rely on PM to lock it's self. PM is set for 10min to auto lock in Firefox (FF) for Browser inactivity, but it doesn't always lock. I mainly use FF, although this issue could also be a problem in other browsers even though I don't touch the PC for 12 hours. I have Win10, 64bit, Max sec Beta II although this also happened in the non Beta version. My PC is set to never goes to sleep, just screen locks, so I always have a web page or more open. I suspect that some web pages have continuous activity and Trend PM seems to detect this activity and not automatically lock. I was very concerned as my PM was potentially unlocked for days. I would personally like to see a timer on PM, rather than monitoring Web page inactivity. This would be more secure as PM then doesn't rely on any other source to secure it's self, but rather to rely on it's own integrity when not used, or just have a timer full stop for 10 min after login. If nobody likes this then make it as an alternative option to the current setting. I would definitely use this option with out hesitation.
Photo of lawrence

lawrence

  • 70 Points
  • Very Concerned

Posted 2 months ago

  • 1
Photo of TM_Ann

TM_Ann, Official Rep

  • 1,880 Points 1k badge 2x thumb
Hi lawrence,

Please try to restart the components of your  Password Manager using the Diagnostic Toolkit, kindly follow the instruction below:
  1. Go to Type here to search field located at the bottom left corner of the screen, then type "Password Manager Diagnostic Toolkit".
  2. Click Trend Micro Password Manager Diagnostic Toolkit.
  3. Click Yes when the User Account Control window appears.
  4. Go to the Components tab, then click Stop Components.
  5. Wait for a few seconds, then click Start Components.
After restarting, please check if the issue will persist.

Hope this helps
- Ann

This conversation is no longer open for comments or replies.