My iPhone 7 just updated to iOS 12.0 (16A366). HAD TO DELETE Mobile Security to USE wifi!

  • 3
  • Problem
  • Updated 1 month ago
  • In Progress
My iPhone 7 just updated to iOS 12.0 (16A366). While "Settings" said that I was connected to my home wifi, the icon in the upper left corner was LTE, not wireless. Similar garble in "Mobile Security" ... on the "SafeSurfing" page the "Wi-Fi Checker" item reported "...not connected to a wifi network...", though the "Wi-Fi Checker" page said i was connected. No TrendMicro updates were pending. Restarting the phone did not help. Disappointing that I had to delete the "Mobile Security" app to solve the problem!
Photo of mike

mike

  • 90 Points 75 badge 2x thumb
  • DISAPPOINTED

Posted 2 months ago

  • 3
Photo of TM_X

TM_X, Official Rep

  • 6,638 Points 5k badge 2x thumb
Hi mike,

Sorry for this inconvenience. Can you please follow the workaround below and let us know how it goes? Our team is currently working on a permanent fix for this.
  1. Turn OFF Content Shield.
  2. Change your mobile device date/time to 3 days later.
  3. Launch Mobile Security and turn ON Content Shield.
  4. Change the device date/time back to the correct one.


Please make sure that the device is not connected to other VPN as this may create conflict. Hope this helps. 

^X
(Edited)
Photo of wdharvey202

wdharvey202

  • 150 Points 100 badge 2x thumb
I have the same issue and the same question.  How do you turn off Content Shield?  Is that the same as Sign Out under Settings?  Currently my iPhone 6 is useful mostly for phone calls as Apps that access the internet cannot because VPN keeps flickering in and out which is also driving my battery down rapidly.  So, how does one turn off Content Shield?  There doesn't seem to be any obvious selection to do so.
Photo of TM_X

TM_X, Official Rep

  • 4,990 Points 4k badge 2x thumb
Hi wdharvey202

Here's how to turn Content Shield on/off: 
  1. On your mobile device, open Mobile Security app.
  2. Tap Content Shield.
  3. To enable or disable, tap on the check icon.
Let us know how it goes. 

^X
Photo of angelfrmbklyn

angelfrmbklyn

  • 74 Points
I have the same issue. I'm so sick of. It actually turns on by itself daily.
Photo of wdharvey202

wdharvey202

  • 150 Points 100 badge 2x thumb
This did not work.  When I tap the Content Shield icon with the check mark it takes me to a DNS screen.  DNS is turned off and greyed out and I cannot turn it on by tapping that check mark of the ON icon.  I think I'm just going to have to Sign Out of TrendMicro on my iPhone as, even though I have an internet connection, the flipping VPN seems to tell most Apps there is no connection so Apps that access the internet are unusable.
Photo of TM_Pat

TM_Pat, Official Rep

  • 7,238 Points 5k badge 2x thumb
Hello wdharvey202,

Can you try to remove the Trend Micro app from the listed VPNs on your phone? To do that, just go to Settings > General > VPN after that, you should see Trend Micro Mobile Security. Kindly remove it from the list to see if it will do the trick.

Regards,
Pat
Photo of wdharvey202

wdharvey202

  • 150 Points 100 badge 2x thumb
I cannot remove the Trend Micro app from the VPN list under Settings/General/VPN because there is no way to remove it.  I have discovered that under Setting/General/VPN that I can click on the "information" icon under Network Shield Protection and it will take me to a page where I can turn off "Connect on Demand".  It works for a while to keep VPN turned off so internet access works OK with it off.  However, it comes back on later automatically so one has to keep making the adjustment perhaps a few times a day.
Photo of angelfrmbklyn

angelfrmbklyn

  • 74 Points
I have the same issue as Mike. When I am home trying to use my Wi-Fi trendmicro mobile security content shield stops it and makes my Iphone use data. Shouldn't have to go through all those steps to stop it. My calendar has important upcoming dates within the next three days. Trendmicro needs to come up with a better solution.
Photo of TM_Pat

TM_Pat, Official Rep

  • 7,328 Points 5k badge 2x thumb
Hi angelfrmbklyn,

Can you try the steps from this link: Issues with the Content Shield feature of Mobile Security on iOS 12

Regards,
Pat
Photo of TM_X

TM_X, Official Rep

  • 6,638 Points 5k badge 2x thumb
Hi all, 

Sorry for the inconvenience. We ask for your patience as our team works on a permanent fix for this. In the meantime, please use the SafeSurfing feature to protect yourself against unsafe websites. Here's how: 

Using SafeSurfing with Mobile Security for iOS

We'll provide you updates once we have one. 

^X
Photo of lynowbridge

lynowbridge

  • 80 Points 75 badge 2x thumb
I found that toggling between System Default and TM Total Safe in DNS Settings of Content Shield will turn VPN on, together with connectivity in Both WiFi and 4G. Unfortunately, have to do this every time on waking up the phone or on Start-up. Fairly stable otherwise.


Photo of TM_Pat

TM_Pat, Official Rep

  • 10,206 Points 10k badge 2x thumb
Hi lynowbridge,

Sorry to hear that you experience this kind of issue. We advise everyone to turn off Content Shield of the Trend Micro Mobile Security app for the meantime while we investigate the problem.

If Content Shield cannot be turned OFF, do the following:

1.    Go to iOS Settings > General > VPN
2.    Tap the blue icon beside Content Shield
3.    Turn OFF Connect on Demand

Regards,
Pat