High CPU with Trend Micro Anti-Malware

  • 2
  • Problem
  • Updated 2 months ago
  • In Progress
This appears a recurring issue in the community. My CPU is running high with TM Anti-malware using 25% continuously. The fan on my laptop is constantly running, which I suspect relates to the computer always working with the Anti-malware. I notice a solution is uninstalling and reinstalling, however I would have though TM would have been able to correct this with some form of update. Is this coming?
Photo of andrewf69

andrewf69

  • 80 Points 75 badge 2x thumb

Posted 3 months ago

  • 2
Photo of TM_Onini

TM_Onini, Employee

  • 692 Points 500 badge 2x thumb
Hi andrewf69 and welcome to the community!

CPU consumption of the Trend Micro program becomes high once it has activity on the background process such us scanning or updating.

Also, Trend Micro program always check for updates every 3 hours. 

Aside from this, high CPU usage of Trend Micro program  can happen due to conflicting software, malware infection or remnants of your old Trend Micro program.

To resolve the issue, kindly check the link below:

Slow PC performance due to high CPU or memory usage

Also, your subscription is entitled for a 24x7 Phone Support.
You may call our toll-free hotline by choosing the Premium Support Number on the link below for a faster resolution regarding this matter:

Contact Trend Micro Technical Support

I hope this helps. Let me know how it goes. :)

Trend Micro Home Users Community
(Edited)
Photo of Fanita

Fanita

  • 84 Points 75 badge 2x thumb
I'm having the same issues. My CPU goes from 20-45%, I feel like my computer is fairly new and I didn't have this problem when I had my previous anti-malware service (Kaspersky). I also did the whole reinstalling and removal tool and such, as stated in the previous conversations and it really did nothing.
Photo of dctorsmurf

dctorsmurf

  • 60 Points
I tried making trend the only startup program and that delayed the spike up to 30 percent cpu usage for about 5 minutes. but the issue still returns. What is so frustrating is that even using the complete removal tool re-installation initially solves the issue but then it comes back
Photo of TM_Malik

TM_Malik, Employee

  • 7,528 Points 5k badge 2x thumb
Welcome to the Home Users Community, Fanita and dctorsmurf. Thank you for sending us these information.

Can we check on the Task Manager which process is consuming the highest CPU usage? You guys can send screenshots if that's okay - the Task Manager only with the list of processes (More Details). This is issue can also possibly caused by remnants of other security programs and Potentially Unwanted programs. So keep a look out for those.

Also, you may try adjusting some settings on Trend Micro program. Go to the Trend Micro Settings > Other Settings > On Startup tab, choose Extra Performance. Then click Apply.

By the way, if the CPU Usage for the Trend Micro process is below 50%, it's normal.

Warm Regards...
(Edited)