High CPU usage with the anti-malware solution platform

  • 3
  • Problem
  • Updated 2 months ago
  • In Progress
Merged

This conversation has been merged. Please reference the main conversation: Information About High Disk Activity of Trend Micro Anti Malware Solution Platform

I have started getting the high CPU usage for a few weeks now, with the anti-malware solution platform jumping between 3% up to 70% regularly, and sometimes higher. I have deleted all the conflicting programmes that are suggested and that I can find but no difference. No viruses or malware have been detected by Trend, and I have not added any new programmes. So why is it suggested to do a complete reinstall?
Photo of rossflynn56

rossflynn56

  • 292 Points 250 badge 2x thumb

Posted 5 months ago

  • 3
Photo of TM_X

TM_X, Official Rep

  • 6,346 Points 5k badge 2x thumb
Hi rossflynn56, 

Were you able to note when this usually occurs? Is the program installing an update or performing a scan whenever this happens? It is possible that there are conflicts among the Trend Micro program that are due to how it was downloaded, installed or modified; hence the suggestion to uninstall and reinstall it. If you haven't done this yet, please do so and let me know the results. 

Thanks, 
Photo of rossflynn56

rossflynn56

  • 292 Points 250 badge 2x thumb
Refer to my previous help desk queries. Twice I have been advised to do a complete uninstall and reinstall. It's OK for a week and returns. Obviously there is more to this problem than a reinstalls. Look at all the posts complaining about this.
Photo of TM_Pat

TM_Pat, Official Rep

  • 9,276 Points 5k badge 2x thumb
Hello rossflynn56,

Thank you for providing these details. Right now, we are still looking into this issue and the suggestion is to perform a clean reinstall. You may follow the instructions below for the clean reinstall procedure.


STEP 1: Uninstallthe Trend Micro program using the Diagnostic Toolkit
  • Press the Windows Button and letter "R" both on your keyboard at the same time to open the Run Console
  • Once the Run Console is open, type: supporttool
  • Click OK
  • Doing that will open the Trend Micro Diagnostic Toolkit. Once open, go to (C) Uninstall and then click on "1. Uninstall Software"
  • Wait for the uninstall process to finish then restart the computer when prompted
  • Note: If your computer cannot find "supporttool", click here to download a tool that will help you uninstall Trend Micro Security.
STEP 2: Run the Remnant File remover tool
  • Click here to download the tool.
STEP 3: Install Trend Micro Security
  • Click here to download the installer.
Should you have any other concern, please do not hesitate to reach out to us.

Regards,
Pat
Photo of rossflynn56

rossflynn56

  • 292 Points 250 badge 2x thumb
Pat, see my comment further below in this thread. Likely solution for my problem and possibly for everyone else too?
Photo of Tj Botha

Tj Botha

  • 62 Points
I personally think that there is essentially a big flaw somewhere with the core of TM. Everyone seems to complain about its high usage. Personally I had similar issues but in general if I look at my task manager and sort Processes to highest usage then TM will appear on the top for almost 60 percent of the time with usage of 3 to 9%. I have 3 desktop PC running windows 10 with almost identical problems. This is ridiculous which tells me the workflow or effectiveness of the background processes are having issues that is  slowing my PC's down too much. Asking to reinstall should be the exception rather than the rule. TM should sort this out as it is clear there are many people with the same problem 
 
Photo of TM_X

TM_X, Official Rep

  • 6,288 Points 5k badge 2x thumb
Hi TJ, 

When the CPU usage of CoreServiceShell.exe is around 70% and takes up 40 MB to 200 MB of memory in a normal computer state or environment, this is considered as normal. If the consumed memory exceeds 200MB and does not go back to normal for about 5 to 10 minutes, its CPU usage is considered HIGH.

Reinstalling the program is not entirely the workaround, it's just that some of our solutions are received via updates which can be installed by downloading the latest installer of the program. 
Photo of sandy

sandy

  • 62 Points
Totally agree, there are posts of this issue going back for 2 years and the TM response is always send us more data (I am not sure if anyone has done this). I have the same issue with the TM anti-malware service in task manager fluctuating between 5 and 30%, it does this every 5 seconds (cycles). Can we get a proper answer please as this is causing a lot of pain when I am working.  FYI - I have an i5 and have included my configuration.
Photo of Tom Emmelot

Tom Emmelot, Champion

  • 24,086 Points 20k badge 2x thumb
Hi  rossflynn56 

Welcome to TM Home users Community, a public site where volunteers try to help each-other , also there are TM Employees that can give answers, that is only at working hours. I am just a volunteer!
Question if you put on "Smart Protection Network again" , does the problem come up again?
 
Kind regards,
Tom
Photo of rossflynn56

rossflynn56

  • 292 Points 250 badge 2x thumb
Tom, every TM employees has told me that I have conflicting software, and to do a reinstall. That failed twice for me.
Actually the CPU usage did go up when I ticked that box again to review it, however I had web pages open at time so it could have been coincidence. I should try that suggestion from you to check it out.
Photo of Tom Emmelot

Tom Emmelot, Champion

  • 24,086 Points 20k badge 2x thumb
Hi rossflynn56
Maybe  the TECHS can pin the problem better than!
 
Kind regards, 
Tom
Photo of TM_Victor

TM_Victor, Employee

  • 4,942 Points 4k badge 2x thumb
Hi ossflynn56,

Regarding the procedures that you have performed which was to disable the Smart Protection Network feature, we do not suggest to disable it as that feature helps us in improving the protection on your device by correlating the information about security risks found on millions of computers worldwide.

Thank you for providing this procedure that you have performed and we are already looking into it for further checking but it should not cause this problem.

Regards,
Photo of rykers.p

rykers.p

  • 60 Points

I have had Trend Micro installed on this Lenovo Yoga since new 2015. This problem persists & gets worse over time. It seems worse with Chrome - Opera is better. At this point, Chrome regularly closes, when I open Task Manager CPU is at 95% - main user is Trend Anti-malware.

I have done the clean install 'solution' (July 2018). It was Ok for a week but is now worse than ever. I am not a techie by any degree - even the process of doing a clean install was difficult (for me) and time consuming - I have used other products on various computers & never had such problems except maybe Norton, which (way back when) was as slow as an old dog.

A user like me has a simple solution: clean uninstall and switch anti-virus. I have 6 months yet on this contract but, at this point, I may switch before renewal.

Also, in Task Manager there is always two instances of TM Anti-Malware Solution Platform running – one is stand alone, the other drops down with TM Solution Platform – they were both there in the old version; gone with the clean install; and back with the clean install. No idea if that is relevant.

(Edited)

This conversation is no longer open for comments or replies.