Cannot view Video on the trainmasters.tv site

  • 1
  • Problem
  • Updated 10 months ago
  • Acknowledged
When I try to view videos on the https://trainmasters.tv site I get the following message This site can’t provide a secure connection

trainmasters.tv uses an unsupported protocol.

ERR_SSL_VERSION_OR_CIPHER_MISMATCH
The client and server don't support a common SSL protocol version or cipher suite. This is likely to be caused when the server needs RC4, which is no longer considered secure.

Is this caused by Trend blocking access or is it some other problem? How can I overcome the issue?
I use a PC running windows XP& use Trend Micro Maximum
Photo of kennethdurham

kennethdurham

  • 80 Points 75 badge 2x thumb

Posted 10 months ago

  • 1
Photo of TM_Malik

TM_Malik, Employee

  • 7,404 Points 5k badge 2x thumb
Hello, kennethdurham and welcome to the Community!

I checked on the error message "ERR_SSL_VERSION_OR_CIPHER_MISMATCH" and confirmed this is a browser error which means this is not caused by the Trend Micro program. 

What we can try as a normal troubleshooting step is to reset your internet browsers, kindly refer on this webpage: Resetting your web browser.

Hope this helps and have a great day!

Trend Micro Home Users Community
Photo of kennethdurham

kennethdurham

  • 80 Points 75 badge 2x thumb
I reset the browser but still have the same problem/message
Photo of Tom Emmelot

Tom Emmelot, Champion

  • 18,738 Points 10k badge 2x thumb
Hi kennethdurham,

did you try a other browser?
Firefox, Opera, Google Chrome, Ei11, Edge?

Kind regards,
Tom
Photo of TM_Dianne

TM_Dianne, Employee

  • 832 Points 500 badge 2x thumb
Hi kennethdurham!

You have mentioned that you are using Windows XP. Upon further investigation, we have found out that The ERR_SSL_VERSION_OR_CIPHER_MISMATCH error happens on older operating systems or browsers. Older operating systems fall out of date with newer technologies such as TLS 1.3 and the latest cipher suites as browsers stop supporting them. Specific components in the latest SSL certs will simply stop working. 

Also, upon checking, you are still using Trend Micro Maximum Security 2015 version. Since Microsoft no longer fixes issues on Windows XP, it has become increasinglydifficult for Trend Micro to keep users safe on this operating system. We recommend allof our users to upgrade their PCs to a more modern operating system which willprovide greater stability and security. To learn more, please refer to the link below:

Trend Micro's official statement for Windows XP's Consumer End of Support (EOS)

Hope this helps. Thank you and have a great day!

Trend Micro Home Users Community