R
Neophyte

Neophyte

 • 

7 Messages

 • 

172 Points

Thu, Nov 12, 2020 10:48 AM

Closed

Home network security box won’t stop blinking red

My device has been disconnecting and re-connecting lately. I don’t know why. In the end I got fed up and reset the black box by holding the reset button. Now it won’t stop blinking red and I don’t know what to do. Even if I switch it off and on again, it just keeps blinking red rapidly beyond 5 minutes.

I even tried switching LAN ports. The device is stuck. Please help

Brand User
tm_krizia

Prodigy

 • 

460 Messages

 • 

5.6K Points

1 y ago

Hi radogna0071v

 

 

Can you please check and follow the instruction on this link? 

Station LED is blinking red (Home Network Security)


May we also know the following information below to further check this? 

 

Router Brand and Model: 
Frequency of the Red Light: 

 

Awaiting your response

-TM_Ann

 

Neophyte

 • 

7 Messages

 • 

172 Points

Hi. Thank you for getting back to me. I have followed all the instructions on the above link but no luck - it still keeps blinking red.

Modem router brand: Technicolor TG-789

Frequency of red light: fast blinking

Brand User
tm_krizia

Prodigy

 • 

460 Messages

 • 

5.6K Points

Thank you, radogna0071v

Can you please follow the instruction below? 

1. Perform a Power Cycle

 

  1. Turn OFF your router and Home Network Security Station by unplugging their power cords.
  2. After a minute, turn ON your router. Wait for 3 to 5 minutes for the router to initialize.
  3. Turn ON your Home Network Security Station.
  4. Your connection will refresh. Check if your Internet connection has improved.

2. Change your connection to your LAN port

 

3. Hard reset your Home Network device by following the instruction on this link: How to reset the Station

 

 

Let us know how it goes
-TM_Ann

Neophyte

 • 

7 Messages

 • 

172 Points

Hi. I have performed all of the above instructions noting that I had to reset the base by holding the reset button rather than through the app because I had deleted and re-installed the app previously. However there is no change to the base station light. It is still blinking red rapidly and it has been over 20 minutes since I pressed the reset button.

Brand User
tm_kath

 Superstar

 • 

589 Messages

 • 

8.2K Points

Hi Anthony,

 

I've sent you an email to further help you with this. Please check it if you receive it.

 

- TM_Kath

Need Help?

Ask the Community